Plugins Don't Wake Up (in Bitwig)

I was asked to make this a seperate post so here it is.

I am on Bitwig 4.4.10, Windows 10.

These are my sandboxing settings:

This is how the inspector settings look like:

Independent of playback or track type (audio track / instrument track), when the plugin is loaded and I close the GUI the plugin with the X-button in the topright the plugin gets suspended after around 2sec if there is silence on the track. note that it doesn’t happen if you close the GUI with the GUI button down on the plugin representation in the effect chain.

So far so good. I guess it is expected that a plugin gets suspended, when there’s no sound. However it doesn’t wake up when the sidechain input has sound again, unless you open the GUI again. It does consistenly wake up when needed if there’s a midi note on event running through the plugin, so my current workaround is to just have one big note going through the entire project:

As far as I could see it’s the same in EXC!TE Cymbal and Snare.

I haven’t tested yet if I can reproduce the bug in different DAWs, but I’ll do that later if I don’t forget it.

@clemens: I’m having a hard time to reproduce this. In Bitwig the plugins don’t go to sleep for me, regardless of the suspend setting in the inspector.

Little update: It doesn’t happen in my version of Cubase (Cubase Artist 9.5.3) so apparently it’s not a windows-thing, but more of a bitwig-thing.

(Also: I didn’t even see the suspend-settings in the inspector view of Bitwig, before you told me about them. So even if the bug is not going to be fixed, I think it would be ok to just tell Bitwig users to set it to “Suspend: Never” and call it a day. It works for me at least.)

We also can’t make Plugins in Bitwig go to sleep at all under Linux. So maybe this function is not implemented there. I have inquired with Bitwig about this.

I just tested under Windows 10 with Bitwig 4.4.10.
I can replicate the issue when no output is selected on the sending channel.

If, however, the output to the track of Exc!te Cymbal is used, the plugin wakes up from sleep as expected.

This seems to be a bug in Bitwig.

On Linux, I see the same behavior.
With previous versions of Bitwig (<4.4.10), our plugins never went to sleep.

Bitwig has confirmed it’s a small bug at their end. The workaround is simple: just deactivate suspending for the plugin entirely.

@magwa101 this is the issue affecting you.