EXCITE SNARE DRUM not working in Waveform on Linux [solved]

Waveform Version 12.1.8 (Built: 28 October 2022) (64-bit)

I tried it with the Linux version and with the Windows version with yabridge, and it comes up with errors for both. Alas!

Hi jub, thanks for getting in touch.
Please provide complete system information.
Please don’t use yabridge, we have a native Linux version of the plugin.
Specify which errors and where.

I only used yabridge as a second resort, just in case it was solely an issue with the Linux version.

Processor Intel(R) Core™ i3-1005G1 CPU @ 1.20GHz
Memory 7886MB (3804MB used)
Machine Type Notebook
Operating System Linux Lite 6.0

I don’t know how to view an error log or anything more detailed within Waveform, alas. It just says a generic “The following file appeared to be a plugin file, but failed to load correctly” message.

Hope that helps

I think I’ve figured it out. I tried installing libxcb-cursor but “sudo apt install libxcb-cursor” ended up returning an error. I did “sudo apt-get install libxcb-cursor0” instead and I think it worked. Now, the vst3 will load! And it makes sound. Alas, the VST GUI doesn’t appear. It’s just a black box. I’m one step closer to the end, at least. Any idea what I should do next?

Thanks for the info. Can you try to load the plugin in a different host, so we know if the issue is related to the OS or the host? Maybe use a demo version of Bitwig?
I have never used Waveform nor Linux Lite before, so I can’t know.

You can try and see if you have the following libraries installed and install them if necessary:
Let us know if that helps making the GUI appear.

Hi Max. Thank you very much! I’ve officially gotten it working. It looks like libxcb-keysyms1 wasn’t installable with apt install. The only one I didn’t have installed besides that was libsqlite3-0, and it appears that was all I needed to get it working. Thanks again!

1 Like

Great to hear! Thanks for letting us know, we’ll add this to the readme.